股市9号课堂:www.gushi9.com
您现在的位置:主页 > 选股技巧大全 > 通达信选股公式 >

通达信超级短线选股公式



通达信超级短线选股公式,短线选股公式。

通达信超级短线选股公式

DRAWRECTREL(300,985,900,980,80);
 DRAWTEXT_FIX(1,0.8,0.985,1,'深挖洞,广积粮'),COLORYELLOW;
AE1:=EMA(CLOSE,13)-EMA(CLOSE,55);
AE2:=EMA((0.618*REF(AE1,1)+0.382*AE1),3);
STICKLINE(AE1>=AE2,H,L,0,0),COLOR00FFFF;
STICKLINE(AE1>=AE2,O,C,-1,0),COLOR0099DD;
STICKLINE(AE1>=AE2,O,C,2,0),COLOR00ABEE;
STICKLINE(AE1>=AE2,O,C,1,0),COLOR00DDFF;
STICKLINE(AE1>=AE2,O,C,0.1,0),COLOR00FFFF;
STICKLINE(AE1<AE2,H,L,0,0),COLOR00FF00;
STICKLINE(AE1<AE2,O,C,-1,0),COLOR009900;
STICKLINE(AE1<AE2,O,C,2,0),COLOR00AB00;
STICKLINE(AE1<AE2,O,C,1,0),COLOR00DD00;
STICKLINE(AE1<AE2,O,C,0.1,0),COLOR00FF00;
 
 P1:=EMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5);
P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);
P3:=CROSS(P2,P1);
P4:=REF(P2,2)<REF(P2,1) AND P2<REF(P2,1);
P5:=COUNT(P3,7)>0 AND P4;
P6:=3*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1)-2*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1);
P7:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
MW:= EMA(P6,5);
 
 NU:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
NU0:=SMA(NU,3,1);
NU00:=SMA(NU0,3,1);
NU10:=3*NU0-2*NU00;
NU1:=EMA(3*NU0-2*NU00,4);
NU2:=SMA(NU1,5,1);
NW:=MA(3*SMA(P7,6,1)-2*SMA(SMA(P7,5,1),5,1),2);
HW:=CROSS(NW,0) AND MW<56;
DP:=IF(P5 AND COUNT(P5,5)=1,1,0);
TP:=(HW AND DP) OR ((CROSS(IF(P6<3 AND NU2<5 AND NW<4,1,0),0.5))AND LLV(L,34)/HHV(H,144)<0.78),NODRAW;
STICKLINE(TP,H,L,0,0),COLOR0000FF;
STICKLINE(TP,O,C,-1,0),COLOR000099;
STICKLINE(TP,O,C,2,0),COLOR0000AB;
STICKLINE(TP,O,C,1,0),COLOR0000DD;
STICKLINE(TP,O,C,0.1,0),COLOR0000FF;
DRAWTEXT(TP,C*0.96,'TURNING POINT'),COLORRED;
 E1:=EXPMA(C,7),COLORGREEN;
 E5:=EXPMA(C,17),COLORGREEN;
 A1A:=CROSS(C,E1) AND CROSS(C,E5);
 DRAWICON(A1A,L*0.99,23);
 S1 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
 LC:=REF(CLOSE,1); 
 RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
 RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
 RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
 S2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
 S3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
 DRAWICON(CROSS(S3,S1) AND RSI1>RSI2 AND RSI2>RSI3,L*0.978,24);
DRAWICON(RSI1>RSI2 AND RSI2>RSI3 AND CROSS(RSI2,RSI3) AND REF(RSI1,2)>50 AND REF(RSI1,1)<50 AND RSI1>50,L*0.97,14);
A1:=IF(REF(S1,1)<-6 AND S1>-6,1,0);
红球:=(A1 AND L>REF(L,1) AND REF(O,1)>REF(C,1))*O;
 DRAWICON(红球=O,L*0.99,13);
 RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100); 
 VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100; 
 TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10); 
 HD:=(HIGH - REF(HIGH,1)); 
 LD:=(REF(LOW,1) - LOW); 
 DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10); 
 DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10); 
 PDI:=((DMP * 100) / TR1); 
 MDI:=((DMM * 100) / TR1); 
 ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5); 
 AV:=(RSI5 + ADX); 
 WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10))); 
 NEWVOL:=(RSI5 - WR10); 
抄底:=(AV + NEWVOL);
 DRAWICON(CROSS(抄底,0),L*0.98,25); 
 VAR4:=EMA(C,3), LINETHICK1,COLORWHITE;
 DRAWICON(COUNT(REF(VAR4,1)<REF(VAR4,2),5)=5 AND VAR4>REF(VAR4,1),L,26);
N:=5;
走势:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLOR0099FF,LINETHICK1;
 RSV:=(CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
超级短线:=SMA(RSV,2,1);
短线:=SMA(超级短线,2,1);
短线狙击:=CROSS(超级短线,短线) AND 超级短线<20;
 DRAWICON(短线狙击=1,L*0.985,34);
RSI1A:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
 RSI2A:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
 RSI3A:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
 RSI4:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
 RSI5A:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
 RSI6:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
 RSI7:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
 RSI8:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100;
 RSI9:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
 RSI10:=SMA(MAX(CLOSE-LC,0),11,1)/SMA(ABS(CLOSE-LC),11,1)*100;
 RSI11:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
 RSI12:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
 RSI13:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
 RSI14:=SMA(MAX(CLOSE-LC,0),15,1)/SMA(ABS(CLOSE-LC),15,1)*100;
 RSI15:=SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100;
 RSI16:=SMA(MAX(CLOSE-LC,0),17,1)/SMA(ABS(CLOSE-LC),17,1)*100;
 RSI17:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
 RSI18:=SMA(MAX(CLOSE-LC,0),19,1)/SMA(ABS(CLOSE-LC),19,1)*100;
 RSI19:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
 RSI21:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
短线RSI:=(RSI1A+RSI2A+RSI3A+RSI4+RSI5A)/5;
中线RSI:=(RSI6+ RSI7+ RSI8+ RSI9+ RSI10+ RSI11+ RSI12+ RSI13+ RSI14+ RSI15+ RSI16+ RSI17+ RSI18+ RSI19+ RSI21)/15;
红色箭头:=CROSS(短线RSI,中线RSI);
 DRAWICON(红色箭头=1,L*0.98,1);
 
 A01:=(C-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3)); 
 A11:=SMA(A01,2,1);
 A21:=SMA(A11,2,1);
 A31:=3*A11-2*A21 ;
 A41:=2*A31-0.5;
生命线:=C*(1-(A41-A21)/15),COLORRED,LINETHICK1;
 A线:=HHV(H,20);
 B线:=LLV(L,20);
 C线:=(A线+B线)/2;
做多线:IF(C线,C线,DRAWNULL)COLORFF00FF;
 MA1:MA(CLOSE,5),COLORWHITE,LINETHICK2;
MA2:MA(CLOSE,10),COLORYELLOW,LINETHICK2;
 MA3:MA(CLOSE,30),COLORGREEN,LINETHICK2;
 MA4:MA(CLOSE,60),COLORBLUE,LINETHICK2;
 MA3A:=MA(CLOSE,20);
DRAWTEXT(CROSS(C,MA1)&&MA1>MA2 AND O<MA3A AND C>MA3A AND MA4>REF(MA4,1) AND O>MA4 AND V>REF(V,1),L*0.995,'黑马出现'),COLORYELLOW;
黑马:=(CROSS(C,MA1)&&MA1>MA2 AND O<MA3A AND C>MA3A AND MA4>REF(MA4,1) AND O>MA4 AND V>REF(V,1));
 DRAWICON(黑马=1,L*0.978,18);
进场:=CROSS(C,生命线);
DRAWICON(进场=1,L,7);
未来压力线:CONST(POW(SQRT(REF(LLV(C,60),60))+1,2));
未来底线:=CONST(POW(SQRT(REF(HHV(C,240),60))-1,2));
超越后压力线1:IF(C>未来压力线,CONST(POW(SQRT(未来压力线)+1,2)),IF(C>未来压力线 AND CURRBARSCOUNT<10,CONST(POW(SQRT(未来压力线)+1,2)),DRAWNULL));
超越后压力线2:IF(C>超越后压力线1,CONST(POW(SQRT(超越后压力线1)+1,2)),IF(C>超越后压力线1 AND CURRBARSCOUNT<10,CONST(POW(SQRT(超越后压力线1)+1,2)),DRAWNULL));
超越后压力线3:IF(C>超越后压力线2,CONST(POW(SQRT(超越后压力线2)+1,2)),IF(C>超越后压力线2 AND CURRBARSCOUNT<10,CONST(POW(SQRT(超越后压力线2)+1,2)),DRAWNULL));
 

这篇有关于通达信超级短线选股公式的文章,希望它对您有帮助。如果您喜欢这篇文章,请分享给您的好友。本站网址:http://www.gushi9.com/ (转载请保留)。


  • 上一篇:通达信底部选股公式

  • 下一篇:通达信指标综合选股公式


  • 相关阅读